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Holiday Village Road, Vajarahalli Village, Mallasandra, off, Kanakapura Rd, 

Bengaluru, Karnataka 560109 

 

VISION 

To impart quality education in engineering and management to meet technological 

business and societal needs through holistic education and research. 

 

MISSION 

K. S. School of Engineering and Management shall, 

o Establish state-of-art infrastructure to facilitate effective dissemination of 

technical and managerial knowledge. 

o Provide comprehensive educational experience through a combination of 

curricular and experiential learning, strengthened by industry-institute interaction. 

o Pursue socially relevant research and disseminate knowledge. 

 

o Inculcate leadership skills and foster entrepreneurial spirit among students. 

 

 

 

DEPARTMENT OF CIVIL ENGINEERING 

 

VISION 

o To emerge as one of the leading Civil Engineering Department by producing 

competent and quality ethical engineers with strong foot hold in the areas of 

Infrastructure development and research. 

 

 

MISSION 

o Provide industry oriented academic training with strong fundamentals and applied 

skills. 

o Engage in research activities in Civil Engineering and allied fields and inculcate 

the desired perception and value system in the students. 



3 

 

 

2 

                                                                          CONTENT PAGE 

 

Sl.No Particulars Page Number 

1 Analysis of plane trusses, continuous beams using software 4 

2 Analysis of portal frames using software 8 

3 Understanding basic features of Project management software. Constructing 

Project: create WBS, Activities, and tasks and Computation Time using Excel 

spread sheet and transferring the same to Project management software. 

12 

       4 Identification of Predecessor and Successor activities with constrain. Constructing 

Network diagram (AON Diagram) and analyzing for Critical path, 

17 

        5 Critical activities and Other non-Critical paths, Project duration, Floats. Study on 

various View options available 

20 

        6 Basic understanding about Resource Creation and allocation g. Understanding 

about Splitting the activity, Linking multiple activity, assigning Constrains, 

Merging Multiple projects, Creating Baseline Project 

22 

       7 GIS applications using open source software: To create shape files for point, line 

and polygon features with a map as reference. To create decision maps for specific 

purpose. 

24 

       8 Computation of earthwork, Design of horizontal curve by offset method, Design 

of super elevation Using Excel 

26 

 

 

 



4 

 

Experiment -01 : Analysis of plane trusses, continuous beams using software 

Step-by-Step Guide to Generate SFD and BMD in ETABS 

Step 1: Create a New Model 

1. Open ETABS and create a new model. 

2. Define the grid system and story levels (if needed). 

3. Set up the material properties (e.g., concrete or steel). 

• Go to Define > Material Properties to create or select materials. 

Step 2: Define Beam Section 

1. Define the beam section properties. 

• Go to Define > Section Properties > Frame Sections. 

• Select or create a beam cross-section (e.g., rectangular or I-section). 

Step 3: Draw the Beam 

1. Use the Quick Draw Frame Element tool or Draw Line Objects tool to draw the beam. 

• Place nodes at the desired locations and connect them using beam elements. 

Step 4: Assign Supports 

1. Assign support conditions to the beam. 

• Go to Assign > Joint > Restraints. 

• Apply pinned or fixed supports to the ends of the beam, depending on your analysis 

requirement. 

Step 5: Apply Loads 

1. Apply loads to the beam: 

• Point Loads: Go to Assign > Frame Loads > Point Loads. 

• Uniform Distributed Loads (UDL): Go to Assign > Frame Loads > Distributed. 

2. Define load cases: 

• Go to Define > Load Cases and add load cases like Dead Load, Live Load, etc. 

Step 6: Run Analysis 

1. Click Run Analysis (play button on the toolbar). 
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• ETABS will calculate the internal forces, deflections, and reactions. 

Step 7: View Results (SFD and BMD) 

1. After the analysis is complete, go to the Display menu. 

• Click Display > Force / Stress Diagrams > Frames/Cables. 

2. In the dialog box: 

• Select the load case (e.g., Dead Load, Live Load, or a combination). 

• Choose the type of force diagram: 

• Shear 2-2 for Shear Force Diagram (SFD). 

• Moment 3-3 for Bending Moment Diagram (BMD). 

3. The shear force and bending moment diagrams will be displayed graphically on the beam. You can 

toggle between different diagrams using the options in the dialog box. 

Step 8: Export Results 

1. To save or export the diagrams: 

• Use the File > Print Graphics option to take a screenshot of the diagrams. 

• Alternatively, use the Snipping Tool (Windows) or another screenshot tool to capture the 

diagrams directly. 

•  

 

Figure 1 : Beam Loading 
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Figure 2: Grid Formation 

 

Figure 3: Loading Details 
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Figure 4: SFD and BMD 
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Experiment -02 : Analysis of portal frames using software 

Step 1: Create a New Model 

1. Open ETABS and select File → New Model. 

2. Define the grid and story data: 

• You can set up a 2D frame grid for the portal frame geometry. 

• Specify the number of bays, spacing, and elevations. 

Step 2: Define Material Properties 

1. Go to Define → Material Properties and define materials for the portal frame members: 

• For steel portal frames, input properties such as modulus of elasticity, density, and yield 

strength. 

• For concrete portal frames, define compressive strength and other relevant properties. 

Step 3: Define Section Properties 

1. Go to Define → Section Properties → Frame Sections. 

• Define the beam and column sections (e.g., I-sections, rectangular sections, or custom sections). 

• Assign appropriate dimensions based on the design requirements. 

Step 4: Draw the Portal Frame 

1. Use the Draw Line Objects tool to model the portal frame geometry: 

• Draw vertical columns and connect them with horizontal/angled beams. 

• Include any bracing or secondary members if necessary. 

Step 5: Assign Supports 

1. Assign boundary conditions to the base of the columns: 

• Go to Assign → Joint → Restraints and select fixed or pinned supports depending on the 

structural design. 

Step 6: Apply Loads 

1. Define load patterns: 

• Go to Define → Load Patterns and create load cases such as Dead Load, Live Load, Wind 

Load, etc. 
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2. Apply loads to the portal frame: 

• Point Loads: Go to Assign → Frame Loads → Point Loads for concentrated loads. 

• Uniform Distributed Loads (UDL): Go to Assign → Frame Loads → Distributed for loads 

such as roof or wall cladding. 

• Wind Loads: Define lateral wind loads and apply them to the frame. 

Step 7: Define Load Combinations 

1. Go to Define → Load Combinations and create combinations such as: 

• Dead Load + Live Load. 

• Dead Load + Wind Load. 

• Custom combinations based on design codes. 

Step 8: Run Analysis 

1. Click the Run Analysis button (play icon on the toolbar). 

• ETABS will compute the internal forces, deflections, reactions, and other results. 

Step 9: View Results 

1. After the analysis is complete, you can view graphical and numerical results: 

• Deformed Shape: Go to Display → Show Deformed Shape to see the frame's behavior under 

loads. 

• Force Diagrams: Go to Display → Force/Stress Diagrams → Frames/Cables to view bending 

moment, shear force, and axial force diagrams. 

• Displacements: Check nodal displacements to ensure the frame's serviceability. 

Step 10: Design and Optimization 

1. Use the ETABS design module to check if the portal frame meets the design code requirements. 

• For steel frames, ETABS can design sections based on codes like AISC. 

• For concrete frames, it can perform reinforcement detailing as per codes like ACI. 

Step 11: Export Results 

1. Generate reports: 

• Go to File → Print Tables to export detailed analysis results. 
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• Use File → Print Graphics to save visual outputs like force diagrams and deformed shapes. 

 

 

Figure 5 : Portal Frame 

 

 

                                                            Figure 6 : Loading Condition 
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                                                                           Figure 7: SFD and BMD 
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Experiment -03 :Understanding basic features of Project management software. Constructing Project: 

create WBS, Activities, and tasks and Computation Time using Excel spread sheet and transfer the same 

to Project management software. 

 

There are 4 essential components In Microsoft Project to create WBS: 

1. Task 

2. Milestone task 

3. Summary Task 

4. Project Summary Task 

 

Figure 8: Task 

Task 

A task is an activity to be performed by a resource. It is last node in the WBS hierarchy. Project is broken down 

into planning packages, planning packages are broken down into further planning or work packages as needed. 

Work packages are broken down into activities also called tasks. Task is not broken down further.  

Milestone task 

A milestone is a point in time and introduced in WBS to denote important events during the project. A milestone 

is a significant stage or event in the development of projects. There is no work involved in the milestone and 
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therefore milestones have no duration. To convert a task into a milestone, please change the duration of task as 

zero. MS Project shows a milestone as diamond on the right hand side chart area in Gantt Chart view.  

 

Summary task 

A summary task is basically a planning package or work package. All the tasks above activity and below project 

name in a WBS Hierarchy are called summary tasks in MS Project. A summary task contains one or more tasks 

under it. 

Project Summary task 

A project summary task is the top level task named same as project name. Refer 1st task in the figure 1. Its id is 

0. To create a project summary task, go to Format tab and tick the check box “Project Summary task” under 

Show/Hide group. A project summary task is inserted at the top. It is named same as project file name and its id 

is 0. All the tasks in the project become sub tasks of this summary tasks.  

Work Breakdown Structure (WBS) 

A Work Breakdown Structure (WBS) in Microsoft Project for construction projects is a hierarchical 

decomposition of the project scope into smaller, more manageable work packages. It's a visual tool that breaks 

down the entire project into tasks and sub-tasks, facilitating planning, organization, and progress tracking. In 

construction, a WBS typically includes levels representing the project phases, major deliverables, and individual 

work packages.  

It is a helpful diagram for project managers because it allows them to break down their project scope and 

visualize all the tasks required to complete their projects. 
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Figure 9: work Breakdown Structure 
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Experiment -04 :Identification of Predecessor and Successor activities with constrain. Constructing 

Network diagram (AON Diagram) and analyzing for Critical path 

Microsoft Project (MSP), predecessors and successors are project tasks that define dependencies between 

activities. A predecessor is a task that must be completed before another task (the successor) can begin or end, 

while a successor is a task that depends on the completion or start of another task (the predecessor). These 

dependencies determine the order in which project tasks are executed.  

 

                                                        Figure 10: Predecessor and Successor activities 

 

Every task is important, but only some of them are critical. The critical path is a chain of linked tasks that 

directly affects the project finish date. If any task on the critical path is late, the whole project is late. 

The critical path is a series of tasks (or sometimes only a single task) that controls the calculated start or finish 

date of the project. The tasks that make up the critical path are typically interrelated by task dependencies. There 

are likely to be many such networks of tasks throughout your project plan. When the last task in the critical path 

is complete, the project is also complete. 
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Show the critical path in the Gantt Chart view 

The Gantt Chart view will likely be your most used view for showing the critical path. 

1. Choose View > Gantt Chart Format. 

2. Choose Format, and then select the Critical Tasks check box 

 

Figure 11: Critical Task 
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Experiment -05 : Critical activities and Other non-Critical paths, Project duration, Floats. Study on 

various View options available 

Total float measures the potential for project schedule delays. Free float more stringently warns of a task’s 

potential for delaying other related tasks. Most scheduling software is helpful because it lists both total float and 

free float data. But the beauty of scheduling software is its ability to describe schedule dynamics in a pictorial 

Gantt chart. 

Displaying both the total float and free float of tasks on the Gantt chart provides the scheduler with greater 

insight into schedule flexibility. In Microsoft Project both float bars may be displayed directly on the Gantt chart 

supporting more in-depth schedule analysis. 

Figure 12 : Float 

Note in particular the ‘Free Slack’ and ‘Total Slack’ data columns, which are Microsoft Project’s terminology 

for free float and total float. The most important tasks to watch are those that have zero total float values. These 

tasks cannot delay without postponing the entire project. Schedulers may also want to locate tasks that cannot 

linger without delaying related successor tasks. Here look for tasks that have zero free float values. 

Zero total float and free float tabulated values provide sufficient warning of potential task or schedule delays. 

However, more insight into schedule flexibility is achieved by displaying total float and free float on the Gantt 

chart. To display both total float and free float on the Gantt chart select Format tab, Bar Styles ribbon group, 

Format, and Bar Styles, Figure 13. 

https://tensix.com/wp-content/uploads/2016/12/Free-Float-Total-Float-Gantt-Chart-Bars-in-Microsoft-Project-Fig-1.jpg
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Figure 2 

In Figure 13 we created a bar to display the total float of all normal tasks. 

Figure 13 : total float of all normal tasks. 

 

Note the bar shape and color in the appearance column. The key to displaying the total float bar is to set the 

‘From’ parameter to ‘Task Finish’ and the ‘To’ parameter to ‘Total Slack’. Let’s now create a bar to display free 

float on the Gantt chart, Figure 14. 

https://tensix.com/wp-content/uploads/2016/12/Free-Float-Total-Float-Gantt-Chart-Bars-in-Microsoft-Project-Fig-2.jpg
https://tensix.com/wp-content/uploads/2016/12/Free-Float-Total-Float-Gantt-Chart-Bars-in-Microsoft-Project-Fig-3.jpg
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Figure 14 : float on the Gantt chart 

Again, note the bar shape and color. The ‘From’ parameter is, again, ‘Task Finish’, and the ‘To’ parameter is 

‘Free Slack’, which works nicely. 

The Gantt chart displaying both total float and free float is in Figure 15. 

Figure 15: Gantt chart displaying both total float and free float 

https://tensix.com/wp-content/uploads/2016/12/Free-Float-Total-Float-Gantt-Chart-Bars-in-Microsoft-Project-Fig-4.jpg
https://tensix.com/wp-content/uploads/2016/12/Free-Float-Total-Float-Gantt-Chart-Bars-in-Microsoft-Project-Fig-5.jpg
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From this total float and free float Gantt chart view we find that task E has the most flexibility. It can delay three 

days without affecting successor task G, and it can delay six days without delaying the entire schedule. 

Experiment -06 : Basic understanding about Resource Creation and allocation g. Understanding about 

Splitting the activity, Linking multiple activity, assigning Constrains, Merging Multiple projects, 

Creating Baseline Project 

A project baseline is a fixed reference point in project management used to track progress and manage 

changes. It's essentially a snapshot of the project plan, including scope, schedule, and cost, agreed upon by 

stakeholders at the beginning of the project. This baseline allows project managers to monitor performance, 

identify deviations, and make necessary adjustments to ensure the project stays on track.  

 

Figure 16:  Baseline of Project 
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In Microsoft Project (MSP), resource allocation is the process of assigning the right resources (work, materials, 

costs) to tasks to meet project goals and deadlines. This involves defining resources in the Resource Sheet, 

assigning them to tasks in the Gantt Chart, and managing their availability and utilization to prevent over or 

under-allocation.  

 

Figure 17: Resource Allocation 
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Figure 18: Resource Allocation 

 

 

Experiment -07 : GIS applications using open source software: To create shape files for point, line and 

polygon features with a map as reference. To create decision maps for specific purpose 

Using open-source GIS software like QGIS, you can create shapefiles for point, line, and polygon features based 

on a reference map and further generate decision maps for specific purposes by utilizing its spatial analysis tools 

and visualization capabilities. Here's a breakdown of the process: 

1. Loading and Referencing the Base Map: 

• Open your base map: 

Import the base map (raster image or vector data) into QGIS. This serves as your spatial reference for placing 

your new features. 

• Set the spatial reference: 

Ensure the base map and your new data share the same coordinate system (projection) for accurate spatial 

relationships. 

2. Creating Shapefiles: 

• Point Features: 

Use the "Digitizing Toolbar" to add point features directly onto the map by clicking on desired locations. You 
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can then add attributes (data associated with each point) like location names or specific data values. 

• Line Features: 

Similar to points, use the line drawing tool to trace lines along features like roads or rivers. 

• Polygon Features: 

Define polygons by clicking and dragging vertices to outline areas of interest, such as land use zones or 

watersheds. 

3. Decision Map Creation: 

• Spatial Analysis: 

• Overlay analysis: Overlap different layers to identify areas where specific conditions intersect 

(e.g., floodplains and populated areas). 

• Buffer analysis: Create buffer zones around features (e.g., a buffer zone around schools). 

• Selection by Attribute: Select features based on their attribute values (e.g., only areas with high 

pollution levels). 

 

 

• Visualization: 

• Symbology: Assign different colors, symbols, or patterns to different features based on their 

attributes to visually represent the results of your analysis. 

• Labeling: Add labels to features for identification. 

• Legends: Create a legend to explain the symbology used in your map. 
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Figure 19:GIS Application 
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Experiment -08 : Computation of earthwork, Design of horizontal curve by offset method, Design of 

super elevation Using Excel 

To design horizontal curves and compute earthwork in Excel, you can leverage formulas and functions to 

automate calculations for elements like radius, tangent length, superelevation, and earthwork volume. The offset 

method is a standard technique for designing horizontal curves, and Excel can be used to implement it 

efficiently.  

1. Design of Horizontal Curve by Offset Method: 

• Input Data: 

Start by inputting data like design speed, curve radius, and any relevant alignment details into an Excel sheet.  

• Tangent Calculation: 

Calculate the tangent length (T) using the formula: T = R * tan(Δ/2), where R is the radius and Δ is the central 

angle.  

• Curve Length Calculation: 

Determine the length of the curve (L) using the formula: L = R * Δ * π / 180, where R is the radius and Δ is the 

central angle in degrees.  

• Offset Calculations: 

Use the offset method to locate points along the curve using the formula: Offset = R * (1 - cos(θ)), where θ is the 

angular distance from the PC.  

• Stationing: 

Calculate the stationing of the PC, PT, and other relevant points along the curve.  

2. Design of Superelevation: 

• Input Data: 

Input design speed, radius of the curve, and road width.  

• Superelevation Calculation: 

Calculate the required superelevation (e) using the formula: e = (V^2) / (127R), where V is the design speed in 

km/h and R is the radius.  

• Check for Limits: 

Ensure the calculated superelevation (e) does not exceed the maximum allowable value (e.g., 0.07) based on 
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design standards.  

 

• Rate of Change: 

Determine the rate at which superelevation should transition from the normal camber to the full superelevation.  

3. Computation of Earthwork: 

• Input Data: 

Input data on ground elevations, cross-section dimensions (e.g., road width, side slopes), and any relevant 

earthwork parameters. 

• Volume Calculation: 

Use the end area method or other suitable methods to compute the earthwork volume between different sections 

of the road. 

• Excel Functions: 

Utilize Excel functions like SUM, AVERAGE, and VLOOKUP to automate calculations and organize data. 

• Cuts and Fills: 

Identify areas of cut (excavation) and fill (embankment) and calculate the corresponding volumes.  

 

Figure 20:Earthwork Calculation 


